1. Check out the Store if you're looking to Buy HL2RP or other schemas for your server. You can click Buy Schemas on the very top navigation bar to visit the store.
  2. Use the Plugin Center to easily subscribe to and auto-install Clockwork plugins to your server, or submit and share plugins you have developed.
  3. Having trouble setting up or developing with Clockwork? Check out the Wiki or post in the Support Forum for advice from fellow users.
Dismiss Notice
Hi Guest, you need a Steam account to register and post on these forums. Login with Steam at the top of the forums to get started!
Dismiss Notice
Hi Guest, do you want to buy HL2RP or another Clockwork schema? Visit the Cloud Sixteen Store to get started!

Gr4Ss' plugin thread v2

Discussion in 'Plugins' started by Gr4Ss, Apr 30, 2016.

  1. Oh god, the types that slipped past me.

    In the file that you see in that error (which has a nice typo in its name already, but that doesn't matter), on line 17 replace 'radationZones' with 'radiationZones'.
  2. The Dovahneer

    The Dovahneer i can change my title Active Member

    i feel fucking retarded for not noticing that

    I'm now unable to place radiation zones.
    The 'RadiationZoneAdd' command has failed to run.
    gamemodes/cwhl2rp/plugins/radiation/plugin/commands/sh_radiationzoneadd.lua:56: attempt to index local 'b' (a nil value)
    Last edited: Jun 17, 2017
  3. karl-police

    karl-police Hotrod turret Templar Clockwork Customer Active Member

    This was the old line:

    table.sort(PLUGIN.radiationZones, function(a, b) return a.scale > b.scale end);
    I'm not good at this atm cause it similar to HUD's because they have scales too so but maybe b doesn't have a scale or doesn't even get placed.

    But it gets stored somewhere here:

            local data = {
                minimum = Vector(math.min(first.x, second.x), math.min(first.y, second.y), math.min(first.z, second.z)),
                maximum = Vector(math.max(first.x, second.x), math.max(first.y, second.y), math.max(first.z, second.z)),
                scale = tonumber(arguments[1])
    again not good with this like making an area where you walk inside it it does something, maybe in hammer editor but not here.
  4. The Dovahneer

    The Dovahneer i can change my title Active Member

    Further testing revealed that it only happens when dealing with decimals for scale, for example 0.5.
  5. guys how to create item, which change bodygroup? I used in-game customzable items, but this item change full model, no bodygroup. Give an example code pls(
  6. Anti-Gas Armor made with this exact code are not able to be unequipped, is there any way to add this function?
  7. Can you help me out? Me & our server's dev are tyring to figure out why the gaszones aren't working. We add them, and the ESP shows it's there, and it tells us when we leave the zone, but we take no damage when entering.
  8. karl-police

    karl-police Hotrod turret Templar Clockwork Customer Active Member

    did you modify the scale?
  9. Hi, in regards to your Gas Zones addon, there are no console commands to create or do anything with the gas zones, any help?
  10. Germanium✔

    Germanium✔ Clockwork Customer

    local ITEM = Clockwork.item:New("filter_base");
    ITEM.name = "Charcoal Filter";
    ITEM.uniqueID = "charcoal_filter";
    ITEM.model = "models/teebeutel/metro/objects/gasmask_filter.mdl";
    ITEM.cost = 0;
    ITEM.weight = 0.5;
    ITEM.business = false;
    ITEM.maxFilterQuality = 1800;
    ITEM.useText = "screw on";
    ITEM.category = "filters";
    ITEM.description = "It's a filter.";
    ITEM.refillItem = "charcoal";


    somehow this item does not show in game anyone know why?
  11. karl-police

    karl-police Hotrod turret Templar Clockwork Customer Active Member

    do you have the armorhl2rp plugin and all that?
  12. Garry[LT]

    Garry[LT] Clockwork Customer

    Hey, did you made "Medical items" plugin?
  13. Hey. I tried enabling the clientside boolean for gaszones and now I run into this error.
    The 'Think' hook has failed to run.
    gamemodes/cwhl2rp/plugins/gaszones/plugin/sh_plugin.lua:29: attempt to call method 'GetFactionTable' (a nil value)

    Anybody have a diagnosis?
    I suppose Clockwork.player is outside the scope of a clientside script. Was able to use
    as a workaround for !Clockwork.player:GetFactionTable(player).noGas
    Last edited: Jan 4, 2019

Previous Readers (Total: 0)